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Preface

When I began teaching 3D character animation almost twenty years ago, 

there were few resources available to help students learn and understand 

the fundamentals of the character rigging process. Because of this, I put 

my classroom materials together and presented them in the �rst edition of 

this book. That was thirteen years ago. Many techniques evolved and new 

practices emerged, but many of the foundations have remained the same. 

This new edition is an almost complete rewrite. Most of the tools covered in 

the �rst edition remain updated along with their menu changes. I removed 

other tools that have phased out of the software and incorporated many 

of the new tools. Included in this edition are Quadruped rigging and Prop 

rigging since there is still little information available about these topics. 

This edition focuses only on rigging, taking feedback from the �rst edition 

to remove the design and modeling content. I also introduce some more 

advanced topics, such as MEL expressions and Node-based rigging solutions, 

giving just a taste to those who crave more than the basics.

Understanding these tools and procedures is a critical component of 

animation in the 3D environment. The technical vocabulary of rigging 

characters is necessary for animators to communicate their needs to 

technical artists. Still, this knowledge is also invaluable to anyone who 

may �nd themselves in a position where rigging becomes part of their job 

description. My goal is to provide a strong foundation in character rigging for 

anyone who wants to pursue 3D animation or more advanced rigging topics.

Essential tips and potential problems are in boxes throughout this book. 

However, because new issues come up with every student and version of 

the software, I have added a section to my website to support this book with 

FAQs and other postings along with resource �les. Please make sure to visit 

and check things out: www.cherylcreates.com

For the best understanding of rigging in Maya, work through this book from 

beginning to end. If more information is necessary or if you have any further 

questions, please contact me via this form: https://www.cherylcreates.com/

contact
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There is something to be said for learning from your mistakes. Throughout 

my twenty years as a professor of 3D character animation, I have seen many 

students make the same mistakes over and over again. I must say that much 

of what I have learned about Maya, I have learned because of the mistakes 

that my students or I have made. Hopefully, our loss will be your gain, and 

you will be able to avoid the same mistakes that we have previously made. I 

am going to show you a streamlined way of creating a character in Maya. The 

method that I am going to show you is an evolved and simpli�ed process, 

and it is one that works for my students and me. It is one that has developed 

as an amalgamation of a variety of approaches that I have learned from 

di�erent people and my own added techniques. It is not the only way to 

accomplish the end result. As with anything in Maya, there is more than one 

way to do the same task. There is no “right way” to achieve your goal. As an 

artist and a student, you should explore di�erent approaches and assimilate 

what works best for you into your own approach.

The work�ow, or production pipeline, is extremely important. There are 

some things that must occur before others and some things that can be done 

simultaneously throughout the production. Throughout each chapter, I will 

be listing the tasks that will be accomplished and specifying an order. You 

should pay close attention to the work�ow because it will save you valuable 

time in the long run.

Overview of the Interface

There are many aspects to the Maya User Interface, and it can be pretty 

overwhelming for a new user. This book does not cover everything that Maya 

has to o�er. If you want more information, make sure to utilize the Maya help 

�les, which can be easily accessed by hitting (F1) on your keyboard. This 

book does assume that you understand 3D space and the XYZ coordinate 

system of establishing points in that space. This section explains some of the 

interface areas that we will frequently be using. Each section in the image 

below is outlined in white and numbered in red. The corresponding number 

that follows below describes that area of the interface. (Figure 0.1)
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 1. Menu Sets. A dropdown to choose which menu you are currently 

working, corresponding with the following hotkeys on the keyboard:

  (F1) Help (Maya Help Files – Read through them when you have spare 

time)

  (F2) Modeling

  (F3) Rigging

  (F4) Animation

  (F5) FX

  (F6) Rendering

 2. Menus. The Menu bar displays seven common dropdown menu 

items (File, Edit, Create, Select, Modify, Display, and Windows), and the 

remaining menu items change based on the current menu set. The 

current menu set can be changed using the hotkeys (above). Some tools 

in the menus have little boxes next to their name on the right. These are 

called option boxes, and clicking on one will open an options window 

where settings can be changed for that tool. As I refer to menu items, 

they will appear in brackets as follows: [Menu > Submenu > Submenu – 

Option Box]. (Figure 0.2)

  Menu items can also be chosen from the Hotbox, which appears when 

you hold down the spacebar. 

  The Hotbox is a quick method for accessing all menu items and tools 

wherever your cursor is located. Simply press and hold down the Space 

bar on the keyboard for it to appear. You can customize the Hotbox: press 

and hold the spacebar, press the LMB, and drag the mouse to the Hotbox 

Controls menu on the right. While still holding the LMB down (a marking 

menu will appear), drag your mouse to the option you want to enable or 

disable, such as SHOW ALL, then release the LMB. Show All will allow all 

menu systems to appear. The Hotbox saves time and frees up valuable 

FIGURE  0.1 The Maya user interface.
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screen space if you hide the menu bar by customizing your settings/

preferences, which will be done later in this section. (Figure 0.3)

  The Marking Menu is a quick method for accessing a subset of menu 

choices of the most commonly used tools for a particular object. Simply 

place your cursor over an object, RMB and hold for the Marking Menu to 

appear. To select an option from a Marking Menu, while still holding the 

RMB down, drag your mouse to the option you want, and then release 

the RMB.

 3. Status Line. The Status Line, or toolbar, contains shortcuts to many of the 

commonly used tools in Maya. We will be using the menu sets, selection 

masks, and sidebar buttons. There are small icon buttons for New Scene/

Open/Save/Undo/Redo. This is followed by Selection Masks by Hierarchy/

FIGURE  0.2 Menu items with option boxes to the right.

FIGURE  0.3 The Hotbox.
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Object/Component, which has a keyboard shortcut of (F8) that toggles 

between Object mode and Component mode. There are more tools on 

the status line, and I recommend reading the help �les to learn more.

 4. User Account menu. Here, you can log in to your Autodesk Account.

 5. Shelves. The Shelves hold commonly used actions and tools, allowing 

them to be accessed by clicking an icon. If you double click on an icon, 

the options window will open. These can help save time if you are using 

the menu bar, but the Hotbox is usually faster. You can create a custom 

shelf by holding down old ⌘ (command) + shift (MAC), or ctrl + shift (PC), 

then select any menu item to add it to the shelf.

 6. Workspace selector. Workspace layout option, which has great options 

for specialized screen layouts of di�erent tasks to increase productivity. 

This book stays with Maya classic.

 7. Sidebar icons. Buttons to quickly change between the following: 

Modeling Toolkit, HumanIK window (for use with Motion Capture Data 

Cleanup), Attribute Editor, and Tool Settings.

 8. Channel Box. The Channel Box is usually the �rst tool for editing object 

attributes. The information displayed in the Channel Box changes 

depending on what kind of object or component you have selected. If 

nothing is selected, then the Channel Box is blank. Click in a �eld to type 

in attribute values, or you can click on a word and middle-mouse-button 

click and drag in the viewport area to change the value.

 9. Layer Editor. The Layer Editor is useful for organizing your Maya scene 

�le. We will be using display layers. Objects can be assigned to a layer 

that can then be labeled and set for display options. Referencing the layer 

allows an object to be viewed normally, but not selectable. Templating 

the layer allows the objects to be viewed as a wireframe, but not 

selectable. You can also turn the visibility of a layer on and o�.

  Animation Layers are for adding changes to base animation.

 10. View Panel (Viewport). This is the main Maya window where you work 

and see what you are working on in three dimensions. There are di�erent 

camera views, and, by default, there is a top, front, side, and perspective 

view. If you tap the spacebar, with your cursor over the view panel, 

your view will change from all four to only the one where your cursor is 

located. There are Panel Toolbars that have the following menus: View, 

Shading, Lighting, Show, Renderer, Panels. The most commonly used 

menu items are on the Panel Toolbar, which is the series of icons.

 11. Tool Box. The tools used to select and transform objects and components 

can be found here in a button format. These tools align with the QWERTY 

hotkeys: (q) Select (w) Move (w) Rotate (r) Scale (t) Show Manipulators (y) 

Last tool used.

 12. Quick Layout/Outliner Buttons. These buttons give you quick access to 

the Perspective view, the four views, and the front/perspective two-panel 

layout. The bottom button shows or hides the Outliner.

  There are more parts of the interface that align more with animation than 

with rigging. Please see the Maya help �les for more information. Two 

more areas that may interest you for rigging are labeled in the image 

above and are:
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  Command Line. Area for entering MEL commands.

  Help Line. Shows information if your cursor hovers over a button and also 

prompts with some steps for certain tools.

Navigation

To navigate in Maya, you need a three-button mouse. Holding down the Alt/

option key and pressing the LMB in the perspective view panel will tumble 

your view. Holding down the Alt/option key and pressing the middle mouse 

button (MMB) in the view panel will track your view. Holding down the Alt/

option key and pressing the right mouse button (RMB) in the view panel or 

viewport will dolly your view. The track and dolly movements also work in 

most Maya windows, such as the Node Editor and Graph Editor – not only in 

the view panels. 

Keyboard with Highlighted Hotkeys

Maya is consistent across all platforms. The only di�erence is that when 

on a Macintosh a tool calls for using the Command key (⌘), on a Windows 

PC, the same would be the Control key (Ctrl). Be aware that Maya is case 

sensitive. This is particularly important when using hotkeys. Throughout this 

book, hotkeys, or keyboard shortcuts, will appear bold in parenthesis (). The 

following are the hotkeys that will be used in this book: (Figure 0.4)

F1 Help (Maya Help Files – Read through them when you have spare time)

F2 Modeling

F3 Rigging

F4 Animation

F5 FX

F6 Rendering

FIGURE  0.4 Common Maya hotkeys used in this book.
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F8 toggles Object mode/Component mode

1 No Smooth Preview

2 Smooth Preview with Wireframe Cage

3 Smooth Preview

4 Wireframe Preview

5 Shaded Preview

6 Textured Preview

7 Light Preview

Q Select

W Move

E Rotate

R Scale

T Show Manipulators

Y Last tool used

P parent, [shift+p] unparent

A frame-all with the cursor over

D (hold) Move pivot [ctrl+d] duplicate selected

F frame selected with the cursor over

G repeats last command [ctrl+G] group or create Null

Z undo

X (hold) snap to grid

C (hold) snap to curve

V (hold) snap to point

B soft select toggle B (hold) change artisan brush size

_−decrease manipulator size

+ = increase manipulator size

{ [ undo camera movement

} ] redo camera movement

Spacebar (tap) display toggle changes Viewport when the cursor is over

Spacebar (hold) shows Hotbox

Insert/home toggle move pivot
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Setting Up Your Project 
Folder and Scene Files

Before you begin working, it is best to develop a �le system for storage and 

organization. Maya has a built-in folder system for storing di�erent aspects 

of your project. If you are organized, you will save valuable time during the 

entire production process. This folder system must be the �rst thing you 

create when you begin a project. By placing all of your �les and related 

resources into this folder and subfolders, you can be assured that Maya will 

be able to �nd your project assets.

To create a new project folder, do the following:

 1. Once Maya is open, go to [File > Project Window], the New Project 

window opens. (Figure 0.5)

 2. Enter the name of the new project in the Name text box [a], for example, 

MayaCharacterRigging.

 3. In the Location: text box, enter or browse to the directory that will contain 

the new project by clicking on the folder icon.

 4. Click Accept .

 5. Maya then creates a default folder structure for your project.

FIGURE  0.5 The Project Window.
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Next, you will want to tell Maya where the project folder is located by doing 

the following:

 1. Go to [File > Set Project…]. The Set Project window opens. (Figure 0.6)

 2. Browse to the folder on your computer.

 3. Click Set .

Setting User Preferences

Preferences in Maya are, well, preferences. Everyone prefers to do things in 

a di�erent way. The reason why Maya is such a powerful program is that it 

is fully customizable. You can con�gure the interface to your particular likes 

and dislikes. My suggestions are what works for me. I will be writing this book 

with these suggestions in place.

To change your settings/preferences:

 1. With Maya open, go to [Window > Settings/Preferences > Preferences].

 2. Click on Animation and set the following: 

 a. Default in tangent: choose “linear.”

 b. Default out tangent: choose “linear” (these settings are best for 

rigging).

 3. Click on Undo and set the following:

 a. Queue: choose “In�nite” (a must, unless you have a slow computer 

that crashes often).

 b. If you have a slow computer: choose “Finite” with a Queue size of 100.

 4. Click Save . (Figure 0.7)

FIGURE  0.6 The Set Project window.
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FIGURE  0.7 The Preferences window.
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FIGURE  1.1 Power-up! Concept art illustration for Lucy Furr by Sanne Methorst, 2019. 
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Former Student Spotlight: David Bokser

Short �lms are tough. They always take way longer than expected and always 

require more work than planned for. No matter how small in scope, a short 

�lm is always a large collection of moving parts involving every aspect of CG 

production – from writing and concept to modeling, animation, lighting, and 

rendering. The rigger/tech artist is a bit of the unsung hero of the production 

phase. While modeling, animation, and lighting often get a lot of the love, the 

tech artist is often the one in the rafters making sure the sca�olding doesn’t 

fall onto the stage and that the lights turn on. 

Rigging and Tech Art is primarily about problem solving, not just putting 

joints into characters and painting skin weights. While working on personal 

short �lms and professional productions, the technical skills that I learned by 

starting with rigging have expanded to almost all other areas of production. 

I’ve had to write tools to help modelers convert meshes into dynamic 

hair curves, joint-based muscle systems because the rendering engine 

didn’t support deformers, and back-end software that allowed artists to 

automatically check their work for errors as they send their assets through 

the pipeline. There are a million tiny cracks in CG production that a technical 

artist can �ll throughout the course of their careers.

Making short �lms helps with getting your hands dirty in all of the details of a 

full CG production. It has helped me �nd those cracks that I could explore in 

parts of production that otherwise never held my interest, and it has helped 

me expand my knowledge and skill sets. If you do decide to make one, my 

suggestion would be to keep it simple. Don’t try to create an epic with your 

�rst �lm; a 30–60 second short would be great. Try to use it as a learning 

process instead of “your great contribution to the art world.” You might end 

up �nding a niche that you didn’t expect.

Biography

David Bokser graduated from the Savannah College of Art and Design with 

a BFA in Computer Art and a minor in Animation. His short �lms have been 

screened at numerous festivals including the SIGGRAPH Electronic Theater, 

the Palm Springs International Shorts Festival, and the SCAD Film Festival. 

He has animated and rigged on commercials for Coca-Cola, Apple, and AMC 

and has directed commercial and interactive media projects for Nintendo, 

PopCap, and Ubisoft. His interests are currently in VR experiences. His work 

can be seen at www.davidbokser.com (Figure 1.2).

Work�ow

Figures 1.3 and 1.4

Introduction

The �rst character you choose to rig should be simple. Keep it SIMPLE. This 

rule applies to anything in life. You will encounter many obstacles while 
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FIGURE  1.2  Love in the Time of Advertising 2015, directed by David Bokser.

FIGURE  1.3 Joint Placement Work�ow part 1.
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learning, so why complicate the situation, unless, of course, you thrive on 

challenges and have no problem tackling these obstacles on your own. 

Generally, however, this leads to frustration and a strong desire to quit. Begin 

simple, then build on that knowledge with practice and add additional 

challenges later.

FIGURE  1.4 Joint Placement Work�ow part 2.
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A biped is a great character for beginning riggers to start with because of the 

varied problems that will be addressed during the process. It is also one of 

the easiest of which to gather research since you are bipedal. When you have 

a question about how something moves, you simply have to study your own 

physical mechanics. Many of the rigging solutions that are used for a biped 

can be reused with other types of creatures and props.

A quadruped can be easier to rig because you may not have to necessarily 

worry about IK/FK switching, �ngers, or other features that are needed for 

bipedal motion. It is important to stick to simple and stylized design ideas 

when learning. The more realistic and detailed the character becomes, the 

more di�cult it is to set up for animation (Figure 1.5). 

Analyzing Motion

The most important thing you need to remember about rigging is to analyze 

the character for the motion that will be necessary and create only the 

controls that are needed for movement. Too many people spend way too 

much time creating rigging features that are not needed or necessary for a 

particular character or prop.

The best way to go about analyzing the motion for a character is to create or 

acquire reference video to study. Of course, you then have to already know 

what action will be needed; otherwise, you have to consider all possible 

motions that a character can do and create a rig that can do everything, 

which could be a waste of time. On the �ip side, you may miss adding 

something to a rig that is needed during production. In some cases, you can 

add these features later to a rig. This is a great example of why preproduction 

is necessary for whatever project you are working on. The more you plan, 

FIGURE  1.5 Biped model by Kenna Hornibrook, design by Crissy Peters, and Quadruped model by Ashley Lupariello, design by Alina Morales, 2019.
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the more you know what you will need, and the less time you will waste in all 

aspects of production (Figure 1.6).

Identifying Pivot Points and Rotations

After you acquire reference video, take a look at the motion of your reference 

actor. Reference video can be created or found. From this video, you can 

advance frame by frame and take notes about what is moving and what 

is staying still. Pay attention to where the pivot locations occur during 

rotational movements. Notice where the center of gravity is located during 

the motion (Figure 1.7). 

Each character or prop will have a center of gravity from which all other parts 

radiate. This center of gravity becomes the root of our character. We can 

compartmentalize a character or prop into speci�c independent rigs that 

are eventually connected together during the animation process. This way, 

we can break apart complicated movements into smaller, more manageable 

sections. Every bipedal human has a center of gravity that usually exists in 

the pelvic area. From here, we can radiate outwards and list the sections that 

need to be created. Going up: torso, neck, head, clavicles, arms, and hands. 

Going down: hips, legs, and feet. 

It is helpful to begin with a drawing of the character, like the character model 

sheet, so that you can make notations of where pivot points are located for 

the necessary rotations. This information becomes extremely helpful when 

creating the underlying skeleton. A screen-capture of the geometry can also 

work well for this (Figures 1.8 and 1.9).

FIGURE  1.7 Still frames from reference video can be used to identify pivot points of rotation and movement.

FIGURE  1.6 Still frames from reference video can be used to analyze motion.
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A character modeled in the T-pose is the easiest to rig. As a beginner 

rigger, it is recommended to only work with characters modeled in a 

T-pose. The reason for this is because the rigging tools were programmed 

to assume perpendicular and parallel grid systems. A-pose characters are 

more di�cult and require additional steps.

FIGURE  1.8 Character Model Sheets can be used for initially marking major pivot locations. Character Model 

Sheet for Persephone by Crissy Peters, 2019.

FIGURE  1.9 Screen captures of the model can be used to mark major pivot locations. Persephone biped model 

by Kenna Hornibrook, design by Crissy Peters, 2019.
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FIGURE  1.10 Joints are connected visually with a bone.

FIGURE  1.11 The hierarchy of a joint chain as seen in the Hypergraph.

A skeletal structure is the support system for our bodies, and the same type 

of structure is needed for our digital characters. This structure is built in Maya 

using joints. Joints are connected visually with bones, but bones do not 

physically exist as objects in Maya. They are simply a visual connection from 

one joint to the next. If you select a bone, you are selecting the joint above 

that bone in the hierarchy (Figure 1.10).

As joints are created, each subsequent joint is automatically connected as 

part of a hierarchy (unless you hit enter, which ends the joint chain). This 

hierarchical system looks much like your family tree. The main di�erence is 

that there are only single parents in the Maya environment. While a joint can 

have many children, the children, however, can only have one parent. When 

you create two joints, the �rst joint is considered the parent, and the second 

joint is considered the child of that parent. Each additional joint created 

becomes a child to the preceding joint. A series of connected joints is called a 

joint chain (Figures 1.11 and 1.12).

The hierarchical system is present in Maya in other ways as well, not just 

with the joint chains. For example, when objects are grouped, the group 

node that is created becomes the parent of all the objects in that group.
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Before creating your joint chains, your character geometry should be 

as �nished as possible. It is unnecessary to complete �ne details in the 

geometry, but the main proportions of the character should be in place 

before beginning the joint placement process. If modeling with polygons, 

it is important not to smooth the �nished model at this point in the rigging 

process as this will create extra geometry which will slow down the entire 

process of rigging and skinning.

When placing joints in your character’s geometry, it is important to study 

the physical shape of the character that you will be rigging. Depending on 

the type of character design for which you are creating controls, the �rst 

place to start would be to research the skeletal structure to ensure proper 

joint placement. For a biped character, this is a simple process since you are 

sitting in the best research available, which is your skeleton. If you need to 

know how something moves or bends, you simply have to look at yourself 

(Figure 1.13).

FIGURE  1.12 The hierarchy of a joint chain as seen in the Node Editor.

FIGURE  1.13 Human and canine skeletons.
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If the character is a creature or something that may not exist in real life, it 

sometimes takes multiple existing animal parts to create a skeletal structure 

that may work for the creature that you are setting up. For example, a dragon 

is part reptile, bat, and bird, so you may want to study the skeletal structures 

of all three to create a basis for the dragon (Figure 1.14). 

When you are placing joints in your character, think about each appendage 

as an individual joint chain. Create separate chains for each leg, arm, �nger, 

torso, and head. These will all be connected as a single skeletal structure. You 

can also add chains for other body parts such as ears, tails, or antennae. You 

can even add joints and joint chains for articles of clothing or props, such as 

neckties or skirts, for better control when animating.

File Referencing [File > Create Reference…]

File Referencing can be found in all menu sets under the File menu.

Many times during the production process, the geometry for a character 

is not �nished when it is time to begin the rigging process. Perhaps the 

textures are not completed or the blend shapes have not been modeled 

yet. In my classroom, the students have only 15 short weeks to learn 

how to create a character. Once their character geometry is �nished, we 

begin the rigging process in class, while outside of class they work on 

retopologizing their character models, UVing, and creating their blend 

shapes and textures. Because of the overlapping work�ow, �le referencing 

is utilized, so that the latest version of the character model can easily be 

updated in the rig �le.

FIGURE  1.14 Dragon skeleton illustration by Drew Merritt. Skeletal in�uences from reptile, bats, and birds are 

clearly de�ned.
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Creating a “File Reference” does not make the �le data part of the current 

scene. Referencing �les only point Maya to a di�erent �le by creating a path 

and saving the path information. When your current scene �le is saved, it is 

not including any data from the referenced �le. It just tells Maya where to 

look when you open the �le again. This reference can easily be removed or 

replaced as you are working. It can even be imported into the scene, so that 

it eventually does become part of the scene �le. File referencing can be used 

during the creation of assets (we will be using it during rigging and skinning), 

but it can also be used when animating.

If your character model scene �le is large (2000 KB), your rig scene �les can 

be very small in size, sometimes under 100 KB, if �le referencing is used. This 

can be helpful if your disk space is limited and you are following the practice 

of saving versions of your �les as you work. Instead of resaving the geometry 

every time you save, the only thing Maya is saving is the rig information.

It is extremely important to always work in a structured and organized way 

to avoid time-consuming problems later. A project folder should be used 

to organize your �les and create relative paths within your project folder. A 

relative path points to a folder or �le within the project folder. This allows 

the ability to move a project folder from one computer to another and 

still maintain a working path structure. Before creating a reference �le, be 

sure to have a project folder created and set your project. Go to [File > Set 

Project…] and browse to the created project folder.

To create a referenced �le, open a new scene in Maya and go to [File > Create 

Reference...□ ] In the option box under “Namespace Options,” make sure 

there is a checkmark  in the box next to “Use Namespaces.” This will ensure 

that the names of the nodes of the referenced �le will not con�ict with any that 

already exist in the current �le, which is extremely important when creating a 

reference for several characters in your animation �le. It is good to get in the 

habit of using namespaces. Maya will use a colon (:) in front of the node name 

to signify that the node is from another �le. The default setting is to use the 

�lename. So, if you are referencing a �le named “model.ma” and there is a 

node called “Left_Arm,” the referenced name will look like “model:Left_

Arm.” If you set “Use selected namespace as parent and add new 

namespace string:” you can type something inside of the available box instead 

of using the lengthy name of a �le. This also allows you to create references to 

multiple versions of the same �le. It is a good idea to keep your �lenames short, 

otherwise, the namespaces become very confusing (Figure 1.15).

Keep �lenames short, especially when using a �le for �le referencing.

Changing the Referenced File [File > Reference Editor]

If you make changes to your model and need to replace the referenced 

�le, go to [File > Reference Editor]. A dialog box will appear. Click on the 

�lename to highlight it, then go to [Reference > Replace Reference]. This 

will open a dialog box that will allow you to browse for a new �le, temporarily 
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remove the reference from your scene, and then reload the new referenced 

�le into the scene. By clicking [Reference > Remove Reference], you can 

permanently remove the reference from your scene. By clicking [File > 

Import Objects from Reference], you can permanently import the reference 

�le into your scene. Be sure to delete construction history, once the objects 

are imported. You can also adjust the path if it is necessary to change an 

absolute path to a relative one (Figure 1.16). 

The proper way to start Maya is to set your project before you begin 

working for the day. You should never double-click directly on a scene 

�le to open Maya, as this will change the relative paths to absolute paths 

when saving your �les. An absolute path looks for the speci�c computer 

on which it was created. This will cause problems, especially with larger 

scene �les and in larger productions, when moving a project from one 

computer to the next, or placing a �le onto a renderfarm.

FIGURE  1.15 Create Reference can be found under the File menu. The Create Reference options window.

FIGURE  1.16 The reference editor.
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Setting Up Your Work Area

Before placing joints, make sure your character is facing front in the front 

view; in the top view, he should be facing down. This may sound obvious, 

but it is my experience that some students do not pay attention to the 

direction their character is facing. The tools in Maya were created with 

the assumption that the character is facing forward in the front view, in 

other words, toward the positive Z-axis in three-dimensional space. If 

for some reason, your character is not facing forward in the front view 

panel, you will need to rotate the geometry. You will need to make a 

group of your geometry if your character is made up of multiple pieces of 

geometry before being able to rotate them together. This should be done 

in the model �le, not in the rig �le, when the geometry is �le referenced. 

Remember, all changes to the geometry should be done in the model �le. If 

you are working on a team, you should communicate this with the modeler 

(Figure 1.17).

The scale of your character is another important consideration. One square 

on the Maya grid is 1 cm by default. I have had students model their entire 

character to �t inside a single 1 cm grid square. Many of the tools used in 

Maya are based on mathematical calculations. The problem with keeping 

your character so small is that these tools must calculate results using 

fractions in the thousandths or smaller. This creates a greater margin for error. 

My general rule is to keep the character arm span the width of the entire grid 

in the perspective window, at a minimum. If, for some reason, your character 

does not have an arm span that is the width of the perspective window grid, 

you will need to scale the geometry. Again, you will need to make a group of 

your geometry if your character is made up of multiple pieces of geometry 

FIGURE  1.17 Proper character placement for rigging. Persephone biped model by Kenna Hornibrook, design by Crissy Peters, 2019.
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before being able to scale them together. (If you had to group them for 

rotational purposes, you can scale the same group, another group is not 

necessary.) Again, this should be done in the model �le. It is important to 

note that once skeletal placement and rigging begins, any changes to the 

scale of the character should happen after the rigging is completed. A good 

rig is scalable and allows a character to be scaled to match the environment 

in which it will exist. It is also a good idea to freeze transformations on all 

geometry or groups in your model scene �le at this point (Figure 1.18). 

It is a good idea to delete the construction history on your geometry before 

you place any joints or bring in your model �le as a reference, if you are 

still working on the geometry. This will ensure that the geometry is free of 

extra and unnecessary information that slows the scene �le down. Once 

the geometry construction history has been deleted, open your Outliner or 

Hypergraph, and take the time to label everything in your scene �le. You can 

also group body geometry if you have multiple pieces. Keeping your scene 

�le organized and clean always saves time later.

DO NOT parent geometry pieces to other geometry pieces unless you 

have done so to create the blend shapes for the face, which I do not 

recommend because it creates some irritating problems that make it 

di�cult to achieve desirable results. Parenting geometry pieces to other 

geometry pieces causes double transformations after the skinning 

process.

Remember that when your character is facing you, his left side is your right 

side. This is important so that as you label all of your joints, you label the 

left and right sides correctly. Make sure to label all joints as this will make an 

organized and clean work�ow and save time later. As you work, save versions 

of your work and save often.

When using a tool in Maya, always open the Option Box and reset the tool 

when using it for the �rst time that day. This ensures that the tool is working 

appropriately and is not based on the tool settings when it was last used.

FIGURE  1.18 The image of the character on the left looks similar in scale to the image of the character on the right. However, on a closer look, the character 

on the left is the scale of the image in the middle. Make sure that your character is not too small, as it will cause problems with some tools and when rigging 

and animating. Persephone biped model by Kenna Hornibrook, design by Crissy Peters, 2019.
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It is a good idea to place the geometry for your character on a display layer. 

Set the layer to reference, so that you are unable to select the geometry 

by mistake when working. Again, this should be done in the model �le. I 

recommend working with shading options set to X-Ray so that you can 

still see your geometry volume. This is a personal preference, as others like 

working in wireframe (Figure 1.19).

• The model should be constructed of quadrilateral polygons with good 

edge �ow. 

• Avoid non-manifold geometry, T-intersections, n-gons, concave 

polygons, double vertices, back-facing polygons, and hidden polygons. 

• Character faces should be built with concentric edge �ow around the 

eyes and mouth. The character should be in the classic T-pose, ready for 

rigging.

• The arms should be aligned with the X-axis. 

• The feet should be toes forward with feet apart. 

• Arms should be modeled palms down with �ngers spread. 

Below is a quick checklist that can be used on the model �le to prepare it for 

rigging (before you create a File Reference). Remember, once you hand your 

model o� to someone else or reference in your �le to begin rigging, do not 

freeze transformations or scale the model.

Model �le checklist:

• Delete construction history on the geometry (with the geometry 

selected, go to [Edit > Delete by type > History]).

FIGURE  1.19 Shading set to X-Ray. Persephone biped model by Kenna Hornibrook, design by Crissy Peters, 2019.
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• Run [Mesh > Cleanup…] (operation: select matching polygons: faces 

with more than 4 sides; Lamina faces; non-manifold geometry: geometry 

only). 

• Fix any problems selected; delete construction history again; repeat 

and continue until problems solved. Sometimes you must change the 

operation to Cleanup matching polygons to remove all problems.

• Make sure your Normals face outward (conform if necessary, then 

reverse).

• Delete construction history again on the geometry. With the geometry 

selected, go to [Edit > Delete by type > History].

• Clean your OUTLINER – delete any unnecessary or extra nodes. 

• Rename all nodes remaining in the OUTLINER so that the nodes make 

sense.

• Freeze transformations on your geometry to return Translations 

and Rotations to 0 and Scale to 1. With the geometry selected, go to 

[Modify>Freeze Transformation].

• Optimize scene size. Go to [File> Optimize Scene Size □] box, CHECK  

everything and click Optimize .

• Be sure that there is only one node remaining in the OUTLINER. Select 

all the geometry, [ctrl+g] to group them, and rename the group 

(Figure 1.20). 

Working with Joints

The Joint Tool [Skeleton > Create Joints]

The Joint Tool can be found in the Animation menu set (F4) under the 

Skeleton menu.

The joint tool allows you to create joints by clicking on a grid. For this reason, 

you should always use the orthographic view panel (front, side, or top) when 

FIGURE  1.20 Optimize Scene Size Options.
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placing your joints. You can create a joint by moving your mouse cursor 

where you would like to position the joint and clicking with the LMB (left 

mouse button). A single joint appears as a circle with a crosshair in the center. 

A new joint is created every time you click the mouse. Subsequent joints are 

connected with bones, which look like a triangle with a line down the center 

pointing toward the new joint. To complete a chain of joints, simply hit the 

(enter or return) key on your keyboard. If you would like to create another 

chain, select the joint tool again by pressing the (y) key.

Remember, a bone does not exist in Maya. It is simply a visual connection 

of one joint to the next.

You will notice that the closer you click the joints to each other, the smaller 

the joints appear. The further away the joints are from each other, the larger 

the joints appear. This can cause visual clutter in your scene �le. This setting 

can be changed by opening the OPTION BOX on the tool and changing the 

long bone radius to 0.5000. By changing the long bone radius to equal the 

short bone radius, all of the joints will be created as the same display size 

(Figure 1.21).

Display Size [Display > Animation > Joint Size…]

Display Size can be found in all menu sets under the Display menu.

As you are drawing your joints, you might notice that they are small or large 

compared to the size of your character model. You can change the display 

size of the joints to see what you are doing more clearly. First, you may want 

to click out a few joints in one of the orthographic view panels. Then after 

opening in the joint display scale window, you can enter any numeric value or 

use the adjustable slider to interactively change the size of the joints.

FIGURE  1.21 The long bone radius changes the size of the joint based on the distance it is from the following 

joint. Changing the long bone radius to 0.5 will prevent this.
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Adjusting the display size of the joint will not a�ect how the joint works. You 

will notice that the position of the center point of the joint does not change 

regardless of the display size (Figure 1.22).

Local Rotational Axes 

To understand the local rotation axis, it is important to understand the 3D 

coordinate system and the di�erences between world space, object space, 

and local space. It is time to think back to math class when you were �rst 

introduced to the Cartesian coordinate system. In the Cartesian coordinate 

system, there are three intersecting perpendicular lines called axes. A point in 

the coordinate system is de�ned by three real numbers (an in�nite decimal 

representation) and each number reveals the position of the point on each 

axis, X, Y, and Z. The point of their intersection is referred to as the origin, and 

it is at the position of 0 0 0.

In Maya, we use a right-handed Cartesian coordinate system, where the 

X-axis points left to right on your screen, the Y-axis points up and down, and 

the Z-axis points forward and backward. This coordinate system is considered 

world space (Figure 1.23).

If you create an object in Maya, such as a sphere, it is placed in world space at 

the origin. Imagine the XYZ axes lines sticking to the sphere (Figure 1.24).

FIGURE  1.22 Display > Animation > Joint Size.

FIGURE  1.23 The Cartesian coordinate system and its point of origin.
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Now imagine the sphere is moved away from the world space origin and 

rotated. The XYZ axes of the object (sphere) would be pointing in a di�erent 

direction and no longer aligning with the world. This coordinate system is 

referred to as object space. The origin is at the object’s pivot point (currently 

at the center of the sphere), and its axes are rotated with the object. The 

origin can be moved by using the move pivot mode (select the move tool (w) 

and then press the (insert) or (d) key). Object space changes for each object 

in Maya, based on its rotation and translation values.

If the object’s transformations are frozen, the axes will return to align with 

world space, but the origin remains where it is currently located, still in object 

space. If an object is the child of another and its parent is transformed, the 

object uses the origin and axes of its parent for its position in parent space. 

This is especially important for translation values, as you can move an object 

based on its object, parent, or world space, and it is particularly noticeable if 

the object has been rotated separately from its parent (Figure 1.25).

The local rotation axis is a separate coordinate system for joints. The local 

rotation axis of a joint is determined by the position of its child. If a joint does 

FIGURE  1.24 A sphere that has been created at the origin and is in World space.

FIGURE  1.25 A sphere (left) that has been moved from the origin and rotated with its parent shows a di�erent coordinate system called Object space. The 

same sphere (right) showing Parent space.
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not have a child, its local rotation axis aligns with world space. If a joint has 

a child, by default its X-axis points toward that child and the Y-axis will point 

upward (or as close to up as it can, based on its relationship to the X-axis). 

We do have to be concerned when the joint chain is vertical or semi-vertical 

because the X-axis points toward up or down (depending on the direction of 

the children), therefore the Y-axis cannot point up at the same time. Maya will 

arbitrarily point the Y in any direction, and the joint chain does not have the 

same local rotation axis throughout (Figure 1.26).

When do you worry about the local rotation axis? To ensure that joints 

rotate uniformly and predictably when using IK (inverse kinematics, will be 

covered in Chapter 2), any joint chain created should be oriented properly for 

IK. This means that the X-axis should be pointing toward the child joint, and 

the Y and Z-axes are the same throughout the chain. This ensures that the IK 

tools will work as the creators de�ned them (Figure 1.27).

However, to ensure that joints rotate correctly using FK, (forward 

kinematics, will also be covered in Chapter 2) the joint orientation must 

align closely to world space. For the arms, we can achieve this alignment 

when drawing out the joints, but for the spine, neck, and head, we will run 

into trouble (and for the ankles and feet, but we will not be setting up FK in 

the legs for this rig). It is impossible to have the X and Y-axes pointing in the 

same direction. This means that the Y-axis should be pointing toward the 

child (up in the spine), and the Z-axis should be pointing forward. To solve 

this problem, we create multiple joint chains for the di�erent types of control 

systems needed and switch between the two. We must reorient the FK chain 

to match world axis (Figure 1.28).

FIGURE  1.26 Local rotation axis set to XYZ on a vertical joint chain, where the axis does not line up from one 

joint to the next.
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The last joint of any chain will not rotate; therefore, the local rotation axis 

position does not matter for that joint.

Placing joints with the default orientation set to primary axis X, secondary 

axis Y, and secondary axis world orientation to Y + will always ensure the 

X-axis points toward the child joint, but the direction of the Y-axis depends 

on the direction of the child joint, especially in vertical or semi-vertical 

chains. If the X-axis is going up or down, then the Y-axis is unable to do so 

as well. This confuses Maya, and it is not sure which direction to place the 

Y. Sometimes the Y-axis will be �ipped in di�erent directions. You will need 

FIGURE  1.27 A spine chain prepared for Inverse Kinematic control.

FIGURE  1.28 A spine chain prepared for Forward Kinematic control.
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to ensure that they are all pointing in the same direction so that the joints 

are aligned. To solve this unpredictable behavior, change the tool settings 

whenever creating vertical joint chains so that the joints are created with the 

primary axis orientation as X and secondary axis orientation is Z. Secondary 

Axis World Orientation would also be Z +. (You could also reorient the joints 

after positioning them.) 

Use this handy guide to help you choose the proper settings when drawing 

joint chains:

Joint chains that will be controlled by IK:

draw on the: Primary 

Axis

Secondary Axis / Secondary 

Axis World Orientation

X-axis (horizontal: left to 

right)

X Y or Z

Y-axis (vertical) X Z

Z-axis (horizontal: front 

to back)

X Y

Joint chains that will be controlled by FK (Figure 1.29):

draw on the: Primary 

Axis

Secondary Axis / Secondary 

Axis World Orientation

X-axis (horizontal: left to 

right)

X Y or Z

Y-axis (vertical) Y X or Z

Z-axis (horizontal: front 

to back)

Z X or Y

FIGURE  1.29 Joint Tool Options set for vertical IK chain creation.
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There are two ways to check the directions of the local rotation axes in your 

character’s joints:

 1. Component mode: press (F8) to change to component mode or click on 

the component mode button. In the selection mask toolbar, place your 

cursor over the “?” button, RMB (right mouse button) click and hold, 

then select Local Rotation Axes from the pop-up menu that appears. In 

the perspective view panel, select the root of the chain you would like to 

display. Every joint in the selected hierarchy will display its local rotation 

axis (Figure 1.30).

 2. Object mode: select the joints you would like to display then go 

to [Display > Transform Display > Local Rotation Axes]. I do not 

recommend displaying the LRA this way for beginners. It can be 

frustrating because to hide them again you have to reselect the 

same joints and repeat the command. Any joints you accidentally add to 

this selection will display the LRA when the others are hidden. This can 

become what seems to be a never-ending cycle of frustration.

Placing Joints

The joint transforms around the position of its center point. It is important 

to make sure that the joint is positioned in the exact place to control your 

character appropriately. As you begin to place joints, you may �nd that you 

have misplaced them in the process. You can [Edit > Undo] or press (z) and 

continue to recreate joints. While placing joints, you can click and hold the 

LMB (left mouse button), then drag the joint into the correct position.

Repositioning Joints

Once you place joints in one of the orthographic views, such as the side, 

front, or top, it is important to look at the perspective view panel to ensure 

correct and proper placement in 3D space. You may notice that the joints are 

not in the proper place and need to be repositioned. Repositioning the joints 

can be done by using the move, rotate, or scale tools.

Moving Joints (also Known as – Translating Joints)

The move tool – keyboard shortcut (w) – will move the selected joint and 

any joints below it in the hierarchy. If the selected joint is the �rst chain in the 

FIGURE  1.30 Display the Local Rotation Axes in Component Mode by right-mouse clicking over the question 

mark. Be sure to select the root of the joint hierarchy before switching to Component Mode (F8) to display the 

Local Rotation Axes for that hierarchy.
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hierarchy, then the entire chain will move. To move an individual joint, you 

must �rst select the move tool by pressing (w) and then press the (insert) 

key to toggle into the move pivot mode. The move pivot mode will allow you 

to move only the selected joint (Figure 1.31).

If you use the move tool to move joints into position, the local rotation 

axis of the translated joint stays at the orientation in which it was created. 

This means that it will no longer be aligned with the child joint. If you 

must move a joint, make sure to reorient the joints.

Rotating and Scaling Joints

The rotate tool – keyboard shortcut (e) – and the scale tool – keyboard 

shortcut (r) – can be used to rotate or scale a joint into place. If a joint is 

rotated or scaled, you MUST freeze transformations on the joint to reset 

rotation values back to zero and scale values back to one. To do this, select 

the top joint of the hierarchy and go to [Modify > Freeze Transformations] 

(Figure 1.32).

Translate values will not freeze on joints. There will always be a value in 

one or all translation channels for a joint. Maya must have translation 

FIGURE  1.31 Moving a joint into place will also move any joints below it in the hierarchy (left), unless the move pivot mode is toggled on by pressing the 

Insert key (right).
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values for a joint so that it knows where that joint is located in world space 

or in relation to its parent joint.

Reorienting Joints [Skeleton > Orient Joint □ ]

After you have �nished placing your joints, I recommend displaying your 

local rotational axes and reorienting them if necessary. There will be special 

circumstances (such as the thumb joints) that will require rotating the local 

rotational axis into position. Also, if you used the move tool to reposition the 

joints into place, the local rotational axis of the translated joint is no longer 

aligned with its child. If you must move a joint, make sure to reorient them.

It is not necessary to reorient a joint if the entire joint chain was moved.

Remember, if you rotated a joint into place, you must �rst freeze 

transformation [Modify > Freeze Transformations] on that joint before 

you reorient. Omitting this step will result in an error message during some 

commands “Warning: Cannot perform joint orientation,” and sometimes the 

joint will be skipped when trying to reorient (Figure 1.33).

To reorient a joint or joint chain, select the joint in object mode OR select 

the axis in component mode and go to [Skeleton > Orient Joint □]. 

UNCHECK □ Hierarchy to orient only one joint, or CHECK  Hierarchy to 

orient that joint and ALL child joints (this option only affects the entire 

hierarchy in object mode; in component mode, you must shift-select 

each joint axis that needs to be reoriented). Choose the orient joint 

FIGURE  1.32 Rotating or scaling joints into place requires the Freeze Transformation command to reset the values to Rotate: 0 and Scale: 1. Joints always 

retain translation information.

FIGURE  1.33 Warning signs for non-zero rotations appear during the reorientation process if the joint’s transformations have not been frozen.
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options and then choose the second axis orientation. Click Apply .  If 

you are in component mode, make sure to press (F8) to change back to 

object mode or click on the component mode button in the Status Line 

(Figure 1.34).

If necessary, you can manually rotate the local rotational axis into position 

when you are in component mode. Select the desired axis with the rotate 

tool by pressing the (e) and adjust in place. When �nished, press (F8) 

to change back to object mode or click on the component mode button 

(Figure 1.35).

You can also change the rotational axis by MEL (Maya Embedded Language) 

command. In component mode, select the desired axis and enter in the 

Command Line the following command (change the numbers and axis as 

necessary) 

FIGURE  1.34 Orient joint OPTION BOX.

FIGURE  1.35 Manual rotation of a joint’s Local Rotation Axis is possible for �ne-tuning joint rotation.
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